Operating Systems compatibility

xMOD™ is compatible with the following operating systems:


Windows version XP (x86) XP (x64) 7 SP1 (x86) 7 SP1 (x64) 8 (x86) 8 (x64)
Windows (stand-alone)
Windows with RTX SMP 2011 SP1 Update 5

External tools compatibility

xMOD™ is compatible with the following tools:

MATLAB/Simulink

  • MATLAB/Simulink 32-bit: From R2007b to R2014b
  • MATLAB/Simulink 64-bit: From R2011b to R2014b

AMESim

  • For integration (Real Time Workshop / Simulink Coder compilation): From Rev8A to Rev14
  • For tool-coupling co-simulation: From Rev11SL1 to Rev14

Dymola

  • For integration (Real Time Workshop / Simulink Coder compilation): 7.2 / 7.4 / 7.4 FD01 / 2012 / 2013 / 2013 FD01 / 2014 / 2014 FD01 / 2015 / 2015 FD01

GT-SUITE

  • For integration (Real Time Workshop / Simulink Coder compilation) and tool-coupling co-simulation: 7.2 / 7.3 /7.4 /7.5

Flowmaster

  • For tool-coupling co-simulation: 7.7.0 / 7.9.1

AVL-Cruise

  • For integration (Real Time Workshop / Simulink Coder compilation): 2011.2

INCA

  • In XCP slave-mode: 7.0

CANAPE

  • In XCP slave-mode: 6.5

Standards compatibility

xMOD™ is compatible with the following standards:

  • FMI 1.0 and 2.0
  • XCP 1.1 (with xMOD in slave-mode)